Twitter YouTube Reddit

System Requirements

Here is a list of all our modpacks and their requirements.

Pack Name

Beyond: Infinity

Mythic

Kinetic

Colony

Infinity

Minecraft Version

1.12.2

1.7.10

1.7.10

1.7.10

1.7.10

Java Version

Java 8

Java 7/8

Java 8

Java 7/8

Java 7/8

RAM Requirements

3GB

3GB

3GB

3GB

4GB

Still Supported?

No Longer Supported

Yes

No Longer Supported

Yes

Yes

Server Requirements.

These requirements are for servers with 10 players, please adjust according to your player count. We also strongly recommend you pregen the world.

Pack Name

Mythic

Colony

Infinity

Minecraft Version

1.7.10

1.7.10

1.7.10

Java Version

Java 7/8

Java 7/8

Java 7/8

RAM Requirements

4GB

4GB

5GB

Still Supported?

Yes

Yes

Yes